dCloudConsole 2.0.13 Missing Custom Apps

Discuss any other Foolish IT app here (including the legacy apps dMaintenance, dSupport, etc.)
Suggest ideas for new Foolish IT apps here also.
Forum rules
1. Try to give more than you take, when possible.
2. Don't be a prick.
3. When posting for help, include the app's version, OS details, and steps to reproduce the issue.

dCloudConsole 2.0.13 Missing Custom Apps

Postby remyservices » Sat May 18, 2013 8:56 pm

Let's see if I can fully explain this. There seems to be a bug in the dCouldConsole for configuring dSupportSuite that causes the Custom Apps for Auto Maintenance to go haywire. I seem to run across it most often when moving my configs from one computer to another however even using a single computer for managing my configs seems to have been bit by it.

If you download dCloudConsole v2.0.13, go to Manage Configs I think the following will reproduce it every time, or at least it does for me.
- Switch to an ID which has Custom Apps for Auto Maintenance.
- Use the Template Manager and copy that Config to a new Template.
- Create a new template, name as you want.
- Copy this template to your Client ID. (Issue seems to also come up when using the Configure Template option)
- Reconfigure this ID and remove all Custom Apps from the list.
- Save the config.
- Change back to your first config which has Custom Apps

For me, the Maintenance apps list is empty now, and sometimes even the Custom Buttons list is void of custom apps. The most odd part is that the .cfg files still exist in the maintapps folder and the sortorder.cfg file is correct. I've seen where switching back and forth from Custom Button to Maint Apps will bring some entries back but not all.

Another issue, not sure if it is related or just in the same area is that the sort order seems to get confused too. It seems to happen when the GUI doesn't show the list properly but I often come back to my sort order being different than I left it and it will be either alpha sorted or where my third and forth entries have moved to the end of the list. All my App Names start with "Step 1 of 11 - " but I've seen it do this to other naming schemes too.

Can anyone else confirm this or know how to prevent it? Is it a bug that can be avoided or do we need to wait for a fix?

Let me know if more info is needed.
remyservices
 
Posts: 85
Joined: Sat May 18, 2013 8:34 pm

Re: dCloudConsole 2.0.13 Missing Custom Apps

Postby remyservices » Sat May 18, 2013 10:14 pm

It seems deleting my SortOrder.cfg file before opening the Custom Apps config will allow the GUI to show all my apps, however once I seem them that first time switching tabs and coming back will present a blank list again.

My SortOrder.cfg is as follows:
step 1 of 11 - temp file cleanup|step 2 of 11 - malware scanners|step 3 of 11 - malware scanners|step 4 of 11 - malware scanners|step 5 of 11 - patching 3rd part apps|step 6 of 11 - temp file cleanup|step 7 of 11 - gathering system info|step 8 of 11 - gathering system info|step 9 of 11 - gathering system info|step 10 of 11 - gathering system info|step 11 of 11 - system drive defrag|
remyservices
 
Posts: 85
Joined: Sat May 18, 2013 8:34 pm

Re: dCloudConsole 2.0.13 Missing Custom Apps

Postby Nick » Sun May 19, 2013 11:12 am

I tried to follow your steps to reproduce the issue but maybe I did something wrong, couldn't reproduce... I will look at it again later.
Author of d7/d7II and other PC technician's tools. http://www.FoolishIT.com

Image
User avatar
Nick
Site Admin
 
Posts: 2718
Joined: Mon Nov 19, 2012 7:54 pm


Return to Other Foolish IT Apps